64位Ubuntu10.10安装QQ以及PPStream

好不容易有国内的软件支持Linux了,PC却也进入了64位时代,而QQ for linux以及PPStream for linux的deb包都是基于i386平台的,因此下载下来直接安装的时候就会报错:Wrong architecture 'i386'。

今天网上Google了一下,找到了解决方案,记下来备查:

 

$ sudo dpkg -i --force-architecture linuxqq_v1.0.2-beta1_i386.deb
$ sudo apt-get install libqt4-core libqt4-gui libqt4-webkit
$ sudo dpkg -i --force-architecture ppstream_1.0.0-1_i386.deb

本文网址:http://blog.perlfect.me/2010/11/11/install-32bit-application-on-64bit-ubuntu.html

comments powered by Disqus